Page MenuHomePhabricator

Small Enlightenment mouse cursors are ugly
Closed, ResolvedPublic

Description

When Enlightenment mouse cursor size is set <20 pixels - it looks ugly. Probably, the issue is theme-related as with the old theme the problem is not present.

Peter2121 added a comment.EditedJan 16 2022, 1:39 PM

I replaced pointer.png in the theme by the old one - it looks really better, but it is cut on the left side. It was the problem with the new pointer cursor too.

the mouse pointer is the SAME size in flat as previous theme.... the difference is pointer is now tagged to scale to it scales with the rest of the theme. scale = 2 ... would hve it be 2x as bit in pixels. scale = 0.8 will be 0.8 times the size... scale 1 will be the exact same size as previous theme... and actually the old cursor is a bit smaller due to the deep black outline using up pixels. here -i scaled the new 128x128 image to 32x32 and pasted it beside the old one:

and in both cases this pointer.png was just filling the whole pointer area (32x32 pixels if scale = 1). so given that you can see the pointer is visually bigger because the black outline is now part of the white pointer... so i can't see how it can now be smaller. it's measurably not smaller.... unless of course its the scaling (but then just replacing the image file would not go make it bigger).

Yes, the old cursor looks smaller because it integrates the black area, and the new one - not.
But the problem is that the cursor is CUT on the left side when I change it's size to <20 pixels. Not scaled, but CUT. I suppose that when I change the size of cursor it will be scaled (at least, it was like this in previous versions of Enlightenment).
It seems that you have very high DPI on your screen, so you don't need so small cursor ;)

oh you change the size... like manually. not relying on scaling.i actually use scale = 1... normally on my desktop. i don't scale i tup. i test scaling on a laptop next to me at scale = 2.... changing cursor size manually actually doesn't even scale the cursor (properly) BECAUSE it now scales with the theme - because theme sets the cursor base image to be 32x32 MULTIPLIED by scale factor... and your manual changing of cursor size actually just reduces the cavas area of a cursosr but doesn't affect scaling. this is a bug allowing setting of the cursor SIZE. this should actually be removed as it's a feature from the very first e17 code years before e17 was released and before we properly did scaling for everything like we do now.

Sorry, raster, but if you want to remove cursor scaling (BTW, why don't you want just scale it correctly??) - you need to add a possibility to change cursor bitmap in E settings! ;)

...and I try to change the size because I use 1.2 scaling factor on my desktop, and the default mouse cursor scaled at 1.2 looks really LARGE, I don't want to work like this!!

that's not how themes work - you don't just get to customize every bitmap that e or efl uses. there are 1000's of them. this is what themes do. there is no way to just "choose a bitmap" because a pointer might be made up of many bitmaps and other elements overplayed and some scale, some don't. some animate (the blue rect that changes is an example - its a rect added to the cursor image that animates - the cursor is both of these together in 1 groups/element that defines this layout and behavior). you CAN go make a custom theme to do whatever you like - but i can't sensibly make a ui where everything is selectable in the ui.

the only person working on e and efl is me. i'm actually cutting down features i don't really need to have there to simplify and make it maintainable. selecting cursor size AND having cursors scale are conflicting things - they both want to "scale a cursor" and since scale settings are the actual preferred way because they scale all the ui uniformly, thus have cursors get bigger if your have a high dpi screen as well as buttons, fonts, icons etc. etc. ... then that is the way it should be done.

i guess i should just make the size a scale 0->8 or something with 1.0 being 32 ...

Yes, it would be nice :)

Peter2121 closed this task as Resolved.Feb 26 2022, 1:51 PM
Peter2121 claimed this task.

Fixed in Enlightenment 0.25.3, the pointer is perfectly scaled now! Thanks!