This here seems gone ?
This here is a try to come up with a design for a group class. I go here with the assertion that any set of radio buttons wants to be added in a group.
build test: https://travis-ci.org/Enlightenment/efl
fixed updates from master
@segfaultxavi this is now fixed.
@cedric This widget is not called view alone but rather Active_View Which refers to the widget as beeing some view to data. Which goes hand in hand with MVVM. And as you pointed out UX is a View class, so is this here. Additionally, this name was the result of 2 days discussion, and i don't feel like i will go back to this discussion, maybe we can go back when we are stabilizing this. But before, i would just merge it with this name. I am really tired of searching names with people, without even knowing if others are happy with the basics.
introduce a new class to do pop / push
use new API from stack
- make tests work without double cmp
With the next update most of the function-wise things are addressed. (Only thing left, is the switch_to thing) Xavi is working on the docs. So if you are happy with the general direction this takes, i would be happy to merge this on the 29.05. If there are other things, i am happy to patch them afterwards, but maintaining such a big patchset is quite a pain. Additionally: I really appreciate that things like "please use active_view instead of page", and i think this is a correct step into the right direction. However, I updated now my revision in this direction, and so i expect that other commit that come into phabricator or directly master also full fill this quality. Same applies btw. for documentation (strongly looking into the direction of efl_ui_grid / efl_ui_list / efl_ui_list_view).
Fri, May 24
I guess we have two options here.
Rebase and cover more case.
I have serious concern with the use of View in the naming as this clash with the View in the concept of MVVM (Model View ViewModel). And View is a UX class. I am bad at naming, so I don't have a great proposal for renaming, but Active_View seems bad to me.
This test should use a for loop to verify that every length of substring works as expected.
I'd like to see explicit handling for a 0 length string (i.e., immediately return null).
Rebasing won't get you out of it.
That's what the resulting string should look like; the format string itself would have more %.
This could probably be merged with D8976 ??
Changes look good, but I think the commit message is a little misleading. Your message seems to indicate the Removal of a null object, but both of these changes involve sub_object_Add lol ;)
Changes make sense, but patch not tested
Fails to build for me because of implicit declaration of function ‘ck_assert_double_eq’ (Old version of libcheck, as usual).
hmmm I have one suggestion,
I do not understand what are you trying to fix here. Can you give an example of a "weird but valid" format string which should not be an error?
some string (maybe more string%) DOES look like an error to me: if the purpose was to have an actual % at the end, it should be doubled.
This code reproduces part of the problem.
This causes build error with --enable-csharp-bindings.
Because Efl.Canvas.Gesture becomes Efl.Gesture and we already have Efl.Gesture.Events.
Efl.Gesture was a namespace in C# but now it becomes a class as well.
Thu, May 23
The problem appeared by switching to EFL-121.1 and E22.
When I go down in version it disappears.
I did not find how to reproduce it, I did not find any factor causing the problem.
I do not understand the opening of this loop, since it was only at the opening of the apps that I found it.
How about separating Efl.Ui.Stack features from Efl.Ui.Active_View.Container?
The documentation changes will be addresses when Xavi goes over the docs and polishes them (happens bebfore this lands.)
I see. As you said, you do not need to fix typo in documentation now but it would be greateful if you comment on documentation which I feel difficult to understand. (e.g. bind)
It would help me to understand better how methods and codes work :)
Rebase and rename.
Rebase, rename and improve doc.