Page MenuHomePhabricator
Feed All Stories

Today

kfx created T7700: Application freezes.
Sat, Feb 16, 3:29 PM · Terminology
kfx added a comment to T7699: Window resize.

efl 1.21.1 enlightenment 0.22.4 xorg-server-1.19.5

Sat, Feb 16, 12:35 PM · Terminology
billiob moved T7699: Window resize from Backlog to Needs Investigation on the Terminology board.
Sat, Feb 16, 9:07 AM · Terminology
billiob added a comment to T7699: Window resize.

I've seen you're using Terminology 1.3.2.
Which version of EFL are you using?

Sat, Feb 16, 9:07 AM · Terminology
billiob merged task T7276: Window shrinks by switching focus into T7699: Window resize.
Sat, Feb 16, 9:06 AM · Terminology
billiob merged T7276: Window shrinks by switching focus into T7699: Window resize.
Sat, Feb 16, 9:06 AM · Terminology
Mikaela added a watcher for Terminology: Mikaela.
Sat, Feb 16, 4:37 AM
bu5hm4n requested changes to D7969: eo: make reflection getter const function..
Sat, Feb 16, 1:11 AM · efl
bu5hm4n accepted D7935: eo: make reflection setter able to return an error code in case of failure..
Sat, Feb 16, 1:11 AM · efl
bu5hm4n added a comment to T7557: efl.object.

@lauromoura Afaics this only affects bindings, but not the efl.object definition perse. @segfaultxavi improved the documentation big time. To me the API looks good, except one tiny thing, i don't know if we want to have allow_parent_unref out of beta or not, because to me this seems like a hack that should not be needed in future, opinions @zmike @cedric.

Sat, Feb 16, 1:06 AM · efl: api, efl (efl-1.22)

Yesterday

woohyun added a comment to T7585: efl.access.window.

@woohyun
As a part of T7653 this interface can be removed completely and moved into efl_access_object. Additionally events can be refactored into regular methods, so instead of "window,created" we will have something like window_created_emit method or just emit with some parameter. Is this acceptable?

Fri, Feb 15, 8:12 PM · efl: api, efl (efl-1.22)
woohyun accepted D7899: api: remove efl.ui.cursor interface.
Fri, Feb 15, 7:44 PM · efl: api
YOhoho added inline comments to D7524: efl_ui_relative_layout: introduce new relative container.
Fri, Feb 15, 5:59 PM · efl
YOhoho updated the diff for D7524: efl_ui_relative_layout: introduce new relative container.

rebase.
add hint_margin in unit test

Fri, Feb 15, 5:58 PM · efl
cedric requested review of D7969: eo: make reflection getter const function..
Fri, Feb 15, 3:06 PM · efl
cedric added a child revision for D7946: efl: for consistency and effiency move Efl.Model event to send stringshare like Property_Bind event.: D7969: eo: make reflection getter const function..
Fri, Feb 15, 3:06 PM · efl
cedric added a revision to T7668: Autogenerate property_bind View : D7969: eo: make reflection getter const function..
Fri, Feb 15, 3:06 PM · efl: mvvm
cedric updated the diff for D7946: efl: for consistency and effiency move Efl.Model event to send stringshare like Property_Bind event..

Rebase.

Fri, Feb 15, 3:05 PM · efl
cedric updated the diff for D7945: efl: add an event for the View to know if someone did bound a property..

Rebase.

Fri, Feb 15, 3:05 PM · efl
cedric added a child revision for D7943: elementary: rely on Efl.Ui.Widget to do more of property binding for MVVM in Efl.Ui.Layout.: D7945: efl: add an event for the View to know if someone did bound a property..
Fri, Feb 15, 3:05 PM · efl
cedric updated the diff for D7943: elementary: rely on Efl.Ui.Widget to do more of property binding for MVVM in Efl.Ui.Layout..

Rebase.

Fri, Feb 15, 3:04 PM · efl
cedric updated the diff for D7942: elementary: Efl.Ui.Image now rely on Efl.Ui.Widget infrastructure for View and Property_Bind..

Rebase.

Fri, Feb 15, 3:04 PM · efl
cedric updated the diff for D7941: elementary: implemente property_bind support on all widget using property reflection..

Rebase.

Fri, Feb 15, 3:04 PM · efl
cedric updated the diff for D7940: efl: add an event to notify that the View property has changed..

Rebase.

Fri, Feb 15, 3:04 PM · efl
cedric updated the diff for D7939: efl: Property_Bind should actually tell us if it succeeded or failed by returning a boolean..

Rebase.

Fri, Feb 15, 2:54 PM · efl
cedric updated the diff for D7938: eo: add tests for efl_property_reflection_exist..

Rebase.

Fri, Feb 15, 2:54 PM · efl
cedric updated the diff for D7937: eo: add efl_property_reflection_exist to be able to know if a property is available on an object..

Rebase.

Fri, Feb 15, 2:54 PM · efl
cedric updated the diff for D7936: eo: return an Eina_Value error when a get for a property is not implemented..

Rebase.

Fri, Feb 15, 2:51 PM · efl
cedric updated the diff for D7935: eo: make reflection setter able to return an error code in case of failure..

Rebase.

Fri, Feb 15, 2:51 PM · efl
segfaultxavi accepted D7968: efl.gfx.stack: restack -> stack,changed.
Fri, Feb 15, 2:41 PM · efl: api
segfaultxavi accepted D7966: efl.screen: add screen_size_in_mm property.
Fri, Feb 15, 2:39 PM · efl: api
segfaultxavi accepted D7965: efl.screen: screen_size -> screen_size_in_pixels.
Fri, Feb 15, 2:38 PM · efl: api
kfx created T7699: Window resize.
Fri, Feb 15, 2:33 PM · Terminology
cedric abandoned D7944: eo: add helper for basic property type reflection..
Fri, Feb 15, 2:04 PM · efl
bu5hm4n added a comment to T7571: efl.ui.focus.object.

This function is called before logical movements are performend, this is esp. usefull to set the explict ordering on a node. Hence, prepare logical. Any ideas for a new name ?

Fri, Feb 15, 1:18 PM · efl: api, efl (efl-1.22)
zmike added a comment to T7571: efl.ui.focus.object.

Yea seems fine on the rename. As for method naming, I meant that prepare_logical is not a super informative method name. What does efl_ui_focus_object_prepare_logical even mean at first glance? Nothing, at least to me...

Fri, Feb 15, 12:33 PM · efl: api, efl (efl-1.22)
bu5hm4n added a comment to T7571: efl.ui.focus.object.

@zmike which one do you mean ?

Fri, Feb 15, 12:29 PM · efl: api, efl (efl-1.22)
zmike closed T7572: efl.ui.cursor as Resolved.

Closing this since we're removing the interface.

Fri, Feb 15, 12:04 PM · efl: api, efl (efl-1.22)
zmike closed T7572: efl.ui.cursor, a subtask of T7553: efl.ui.widget, as Resolved.
Fri, Feb 15, 12:04 PM · efl: api, efl (efl-1.22)
zmike requested review of D7968: efl.gfx.stack: restack -> stack,changed.
Fri, Feb 15, 12:04 PM · efl: api
zmike added a revision to T7560: efl.gfx.stack: D7968: efl.gfx.stack: restack -> stack,changed.
Fri, Feb 15, 12:04 PM · efl: api, efl (efl-1.22)
zmike added a comment to T7560: efl.gfx.stack.

So I think all we need here is to rename the event? I'm on it.

Fri, Feb 15, 12:03 PM · efl: api, efl (efl-1.22)
zmike moved T7570: efl.part from "easy" to Stabilized on the efl: api board.
Fri, Feb 15, 11:59 AM · efl: api, efl (efl-1.22)
zmike updated the diff for D7967: efl.screen: add screen_scale_factor property.
Fri, Feb 15, 11:57 AM · efl: api
zmike updated the diff for D7966: efl.screen: add screen_size_in_mm property.
Fri, Feb 15, 11:57 AM · efl: api
zmike updated the diff for D7965: efl.screen: screen_size -> screen_size_in_pixels.
Fri, Feb 15, 11:57 AM · efl: api
cedric accepted D7964: efl-api: Mark Efl.Loop_Consumer as stable.
Fri, Feb 15, 11:55 AM · efl
cedric accepted D7916: efl_ui_scrollable: add step size property.
Fri, Feb 15, 11:53 AM · efl
zmike planned changes to D7967: efl.screen: add screen_scale_factor property.
Fri, Feb 15, 11:50 AM · efl: api
cedric added a comment to D7899: api: remove efl.ui.cursor interface.
In D7899#142019, @zmike wrote:

I think @woohyun is making a good suggestion here.

Yes, but that's outside the scope of this patch.

Fri, Feb 15, 11:50 AM · efl: api
zmike added a comment to T7571: efl.ui.focus.object.

The method naming here seems a bit uninformative?

Fri, Feb 15, 11:46 AM · efl: api, efl (efl-1.22)
segfaultxavi requested changes to D7967: efl.screen: add screen_scale_factor property.
Fri, Feb 15, 11:46 AM · efl: api
zmike added a comment to D7899: api: remove efl.ui.cursor interface.

I think @woohyun is making a good suggestion here.

Fri, Feb 15, 11:45 AM · efl: api
cedric added a comment to D7899: api: remove efl.ui.cursor interface.

I think @woohyun is making a good suggestion here.

Fri, Feb 15, 11:45 AM · efl: api
zmike added a comment to T7553: efl.ui.widget.

Why does this have a moved event?

Fri, Feb 15, 11:43 AM · efl: api, efl (efl-1.22)
cedric accepted D7955: interfaces: move pointer_iterate method efl.canvas.scene -> efl.ui.win.
Fri, Feb 15, 11:43 AM · efl
zmike added inline comments to D7966: efl.screen: add screen_size_in_mm property.
Fri, Feb 15, 11:42 AM · efl: api
segfaultxavi requested changes to D7966: efl.screen: add screen_size_in_mm property.
Fri, Feb 15, 11:41 AM · efl: api
segfaultxavi accepted D7965: efl.screen: screen_size -> screen_size_in_pixels.
Fri, Feb 15, 11:38 AM · efl: api
zmike added a comment to T7383: Efl.Config and Efl.Config_GLobal.

What's going on here?

Fri, Feb 15, 11:04 AM · efl (efl-1.22)
zmike added a subtask for T7592: efl.config: T7383: Efl.Config and Efl.Config_GLobal.
Fri, Feb 15, 11:04 AM · efl: api, efl (efl-1.22)
zmike added a parent task for T7383: Efl.Config and Efl.Config_GLobal: T7592: efl.config.
Fri, Feb 15, 11:04 AM · efl (efl-1.22)
zmike added a comment to T7590: efl.screen.

I've created patches for the above, though the new properties lack implementations. This can be solved at a later point.

Fri, Feb 15, 11:01 AM · efl: api, efl (efl-1.22)
zmike requested review of D7967: efl.screen: add screen_scale_factor property.
Fri, Feb 15, 11:01 AM · efl: api
zmike added a child revision for D7966: efl.screen: add screen_size_in_mm property: D7967: efl.screen: add screen_scale_factor property.
Fri, Feb 15, 11:01 AM · efl: api
zmike added a revision to T7590: efl.screen: D7967: efl.screen: add screen_scale_factor property.
Fri, Feb 15, 11:01 AM · efl: api, efl (efl-1.22)
zmike requested review of D7966: efl.screen: add screen_size_in_mm property.
Fri, Feb 15, 11:01 AM · efl: api
zmike added a child revision for D7965: efl.screen: screen_size -> screen_size_in_pixels: D7966: efl.screen: add screen_size_in_mm property.
Fri, Feb 15, 11:01 AM · efl: api
zmike added a revision to T7590: efl.screen: D7966: efl.screen: add screen_size_in_mm property.
Fri, Feb 15, 11:01 AM · efl: api, efl (efl-1.22)
zmike requested review of D7965: efl.screen: screen_size -> screen_size_in_pixels.
Fri, Feb 15, 11:01 AM · efl: api
zmike added a revision to T7590: efl.screen: D7965: efl.screen: screen_size -> screen_size_in_pixels.
Fri, Feb 15, 11:01 AM · efl: api, efl (efl-1.22)
zmike added a comment to T7590: efl.screen.

So maybe something like:

Fri, Feb 15, 10:48 AM · efl: api, efl (efl-1.22)
cedric added a comment to T7376: [MVVM] Model Selection Support.

We could merge the idea of multi selection and selection class model into one class easily, so let's do it that way.

Fri, Feb 15, 10:20 AM · efl (efl-1.22), efl: mvvm
cedric added a comment to T7672: efl.file_save.

For the long term, I would love to have a way to load from an Efl.Io stream as a load function, could be load_from_io then.

Fri, Feb 15, 10:03 AM · efl: api, efl (efl-1.22)
cedric added a comment to T7672: efl.file_save.

I think I agree with @segfaultxavi here on most bit:

Fri, Feb 15, 10:01 AM · efl: api, efl (efl-1.22)
zmike added a comment to T7672: efl.file_save.

I initially listed some concerns, which you addressed with specific proposals:

In T7672#130634, @zmike wrote:

To propose a more concrete change here:

  • move existing efl_file(_save) into efl_gfx (either directly or as efl.gfx.file)
  • keep simple efl.file mixin with only file property
    • remove key
  • keep simple efl.file_save interface
    • remove flags
  • create file_key property to go with the file api which has been moved to efl_gfx
  • create save_flags property to go with file api in efl_gfx

And we all agreed, so you are free to implement those.

Afterwards, I also complained (like the tireless little whiner that I am) about the asymmetry of having save() but no load(), and the fact that the filename you save() to is not the same you will retrieve later when reading the file property.
@cedric agreed that conventional load() and save() methods would be nice, but warned us that some work will then be required to link these methods with a filename property on a Model object. I do not know what this work is, but Cedric thinks it is doable.

And this is the TL;DR, as I understand it.

Fri, Feb 15, 10:00 AM · efl: api, efl (efl-1.22)
segfaultxavi added a comment to D7934: Efl.Gfx.Stack: Rename raise and lower.

actually raise and lower mean to top and bottom commonly. xrwaisewindow and xlowerwindow certainly do. in Qt its raise() and lower() methods.

Well, raise() and lower() already proved to be confusing (since both @cedric and myself understood them incorrectly). The X API is famous for being laconic.

Fri, Feb 15, 9:29 AM · efl
segfaultxavi added a comment to D7934: Efl.Gfx.Stack: Rename raise and lower.

actually raise and lower mean to top and bottom commonly. xrwaisewindow and xlowerwindow certainly do. in Qt its raise() and lower() methods.

Well, raise() and lower() already proved to be confusing (since both @cedric and myself understood them incorrectly). The X API is famous for being laconic.

Fri, Feb 15, 9:24 AM · efl
segfaultxavi added a comment to T7562: efl.input.interface.

Oh, I thought to meant "conceptual" overlap, sorry.

Fri, Feb 15, 8:56 AM · efl: api, efl (efl-1.22)
bu5hm4n accepted D7963: meson: edje: setup edje_codegen for cross-builds as well.
Fri, Feb 15, 8:51 AM · efl
segfaultxavi added a comment to T7574: efl.ui.selection.

Looks like that, yeah.

Fri, Feb 15, 8:44 AM · efl: api, efl (efl-1.22)
zmike added a comment to T7562: efl.input.interface.
(E) focus,in
(E) focus,out
Fri, Feb 15, 8:43 AM · efl: api, efl (efl-1.22)
segfaultxavi updated subscribers of T7563: efl.gfx.size_hint.

I do not like the name of this interface. First off, it not only contains size hints, also position (like hint_align). I'd prefer something like Efl.Gfx.Geometry_Hint.
Secondly, Size_Hint suggests that this is a hint, instead of an object accepting hints, but I cannot come up with a better name for that.

Fri, Feb 15, 8:39 AM · efl: api, efl (efl-1.22)
segfaultxavi added a comment to T7555: efl.canvas.object.

I agree is_frame_object() seems internal, as its own docs say.

Fri, Feb 15, 7:56 AM · efl: api, efl (efl-1.22)
segfaultxavi added a comment to T7562: efl.input.interface.

Where? I cannot find any overlap.

Fri, Feb 15, 7:41 AM · efl: api, efl (efl-1.22)
segfaultxavi added a comment to T7672: efl.file_save.

I initially listed some concerns, which you addressed with specific proposals:

In T7672#130634, @zmike wrote:

To propose a more concrete change here:

  • move existing efl_file(_save) into efl_gfx (either directly or as efl.gfx.file)
  • keep simple efl.file mixin with only file property
    • remove key
  • keep simple efl.file_save interface
    • remove flags
  • create file_key property to go with the file api which has been moved to efl_gfx
  • create save_flags property to go with file api in efl_gfx

And we all agreed, so you are free to implement those.

Fri, Feb 15, 7:36 AM · efl: api, efl (efl-1.22)
segfaultxavi added a commit to T7584: efl.canvas.scene: rEFL4935202caab9: efl.canvas.scene: improve class docs.
Fri, Feb 15, 7:24 AM · efl: api, efl (efl-1.22)
segfaultxavi closed D7954: efl.canvas.scene: improve class docs.
Fri, Feb 15, 7:24 AM · efl
segfaultxavi accepted D7954: efl.canvas.scene: improve class docs.

That is usually my approach too :D

Fri, Feb 15, 7:15 AM · efl
zmike added a comment to T7574: efl.ui.selection.

I don't think there's any way this makes it for 1.22 given that it goes with T7575 and requires dnd/selection types...

Fri, Feb 15, 6:50 AM · efl: api, efl (efl-1.22)
zmike added a comment to T7563: efl.gfx.size_hint.

Not totally sold on hint_margin naming? Was this hint_padding or similar at some point?

Fri, Feb 15, 6:49 AM · efl: api, efl (efl-1.22)
zmike added a comment to T7555: efl.canvas.object.

is_frame_object seems bad to expose since this should only be used by internals?

Fri, Feb 15, 6:48 AM · efl: api, efl (efl-1.22)
zmike added a comment to T7562: efl.input.interface.

This seems like it has some overlap with T7584?

Fri, Feb 15, 6:47 AM · efl: api, efl (efl-1.22)
zmike moved T7582: efl.layout.signal from needs patch to Stabilized on the efl: api board.
Fri, Feb 15, 6:43 AM · efl: api, efl (efl-1.22)
zmike moved T7559: efl.gfx.color from needs patch to Stabilized on the efl: api board.
Fri, Feb 15, 6:43 AM · efl: api, efl (efl-1.22)
zmike moved T7567: efl.canvas.pointer from needs patch to Stabilized on the efl: api board.
Fri, Feb 15, 6:43 AM · efl: api, efl (efl-1.22)
zmike moved T7576: efl.container from needs patch to Stabilized on the efl: api board.
Fri, Feb 15, 6:43 AM · efl: api, efl (efl-1.22)
zmike moved T7589: efl.input.state from needs patch to Stabilized on the efl: api board.
Fri, Feb 15, 6:43 AM · efl: api, efl (efl-1.22)
zmike moved T7593: efl.ui.widget_focus_manager from needs patch to Stabilized on the efl: api board.
Fri, Feb 15, 6:43 AM · efl: api, efl (efl-1.22)
zmike moved T7588: efl.content from needs patch to Stabilized on the efl: api board.
Fri, Feb 15, 6:43 AM · efl: api, efl (efl-1.22)