Page MenuHomePhabricator

Jaehyun_Cho (Jaehyun Cho)
User

Projects

Today

  • Clear sailing ahead.

Tomorrow

  • Clear sailing ahead.

Friday

  • Clear sailing ahead.

User Details

User Since
Jul 24 2013, 3:26 AM (330 w, 9 h)
Availability
Available

Recent Activity

Fri, Nov 15

Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

However, if we finish task T8474, we could have only one animation_start() method with default values, so in C# you could use StartAnimation(anim) or StartAnimation(anim, speed, starting_pos). I think this would be the nicest solution.

To revert an animation, in C#, you just need to do:

obj.StartAnimationFull(old_anim, -1.0, obj.AnimationProgress);
Fri, Nov 15, 1:36 AM · efl
Jaehyun_Cho added a comment to T8474: C#: Support optional parameters.

This is exactly required for C#!

Fri, Nov 15, 1:26 AM · efl: language bindings

Thu, Nov 14

Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

This is already done for all @move Efl.Object parameters, like setting the manager in the Container and setting the animation in this patch.

Thu, Nov 14, 7:06 AM · efl
Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

@segfaultxavi @bu5hm4n
I missed asking you one more thing in the original comment.

Thu, Nov 14, 6:57 AM · efl
Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

As StartAnimation receives their animation object by @move, the C# binding will automatically call efl_ref for it.

Thu, Nov 14, 6:13 AM · efl
Jaehyun_Cho updated subscribers of D10615: introduce efl_canvas_object_animation.

@segfaultxavi @bu5hm4n
Thank you very much for the comments! :)

Thu, Nov 14, 3:26 AM · efl

Tue, Nov 12

Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

I share the collected opinions about refactoring of Canvas Animation as follows.

Tue, Nov 12, 11:10 PM · efl
Jaehyun_Cho accepted D10654: wl_egl : Prevent access to NULL pointer.
Tue, Nov 12, 8:44 PM · efl

Mon, Nov 11

Jaehyun_Cho closed D10648: evas_device: Fix typo in evas_device_pop.
Mon, Nov 11, 11:23 PM · efl
Jaehyun_Cho accepted D10648: evas_device: Fix typo in evas_device_pop.
Mon, Nov 11, 11:22 PM · efl
Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

I am afraid I need some more time (1 or 2 days) to give you opinion about this animation refactorying work.

Mon, Nov 11, 2:31 AM · efl

Thu, Nov 7

Jaehyun_Cho added a comment to T8288: Animation API.
  1. If pause like this is a *must* have, then we can introduce it to this mixin and support this case. No problem with that. We just have 0 usages of that right now so I saw no purpose in carrying it over (further more, the pause feature in the player object does not work at all like pausing, it will restart the animation from the begining when you unpause it, which is why I said this is totally equivalent to start stop. The problem you are describing is also happening right now in the player class, pausing is resetting the mapping.).

I think "pause" and "resume" are basic functions for animation. It is hard to find framework that support animation without "pause". So I think that we need to support it.
Even though "pause" is not perfectly supported now, I think it would not be a reason why we do not need to consider "pause".
BTW, for now, it seems that "pause" works with Efl.Canvas.Animation_Player without resetting mapping. (elementary_test -> Efl.Animation.Pause ->Pause Animation/Resume Animation)
If we add "pause" to the new mixin, then I am worried if it would look fine by design aspect that supporting animation control functions to canvas object (by implementing new mixin).

Thu, Nov 7, 5:00 AM · efl: canvas
Jaehyun_Cho added a comment to T8288: Animation API.

I totally understand the reason of your idea. I think it implies the followings.

  1. Set one animation to multiple canvas object.
    • To support this, animation should not support animation controls such as "Start" and "Stop".
  2. Support animation simpler.
    • To support this, Efl.Canvas.Animation_Player is removed because it implements way too much methods. And new mixin is introduced with small number of methods.
Thu, Nov 7, 3:02 AM · efl: canvas
Jaehyun_Cho added a comment to T8288: Animation API.

Please could you give your thoughts about this discussion? (i.e. Introducing new mixin with animation_start/animation_stop for Efl.Canvas.Object)

Thu, Nov 7, 2:19 AM · efl: canvas
Jaehyun_Cho updated subscribers of T8288: Animation API.
Thu, Nov 7, 2:14 AM · efl: canvas

Wed, Nov 6

Jaehyun_Cho closed D10596: efl_ui_alert_popup: add title part in parts block.
Wed, Nov 6, 9:52 PM · efl
Jaehyun_Cho accepted D10596: efl_ui_alert_popup: add title part in parts block.
Wed, Nov 6, 8:38 PM · efl
Jaehyun_Cho added a comment to T8288: Animation API.

I am worried that adding additional methods to the new mixin would make the new mixin complicated like Efl.Canvas.Animation_Player unlike the initial purpose.

Wed, Nov 6, 12:50 AM · efl: canvas

Tue, Nov 5

Jaehyun_Cho added a comment to D10596: efl_ui_alert_popup: add title part in parts block.

In 1.23 release, we opened Efl.Ui.Alert_Popup without @beta but we still kept Efl.Ui.Alert_Popup_Part with @beta.

Tue, Nov 5, 11:21 PM · efl
Jaehyun_Cho requested changes to D10596: efl_ui_alert_popup: add title part in parts block.
Tue, Nov 5, 4:53 AM · efl

Fri, Nov 1

Jaehyun_Cho accepted D10350: efl_canvas_animation_rotate: adjust API.

Seems ok to me.
Same comment with @zmike about "center_pointer".

Fri, Nov 1, 4:14 AM · efl
Jaehyun_Cho added a comment to T8288: Animation API.

Basically I like the idea (P) animation :)

Fri, Nov 1, 3:58 AM · efl: canvas

Mon, Oct 28

Jaehyun_Cho created T8453: efl.spring_interpolator.
Mon, Oct 28, 7:58 PM · efl (efl-1.24)
Jaehyun_Cho created T8452: efl.sinusoidal_interpolator.
Mon, Oct 28, 7:56 PM · efl (efl-1.24)
Jaehyun_Cho created T8451: efl.linear_interpolator.
Mon, Oct 28, 7:56 PM · efl (efl-1.24)
Jaehyun_Cho created T8450: efl.divisor_interpolator.
Mon, Oct 28, 7:55 PM · efl (efl-1.24)
Jaehyun_Cho created T8449: efl.cubic_bezier_interpolator.
Mon, Oct 28, 7:55 PM · efl (efl-1.24)
Jaehyun_Cho created T8448: efl.bounce_interpolator.
Mon, Oct 28, 7:54 PM · efl (efl-1.24)
Jaehyun_Cho created T8447: efl.decelerate_interpolator.
Mon, Oct 28, 7:54 PM · efl (efl-1.24)
Jaehyun_Cho created T8446: efl.accelerate_interpolator.
Mon, Oct 28, 7:53 PM · efl (efl-1.24)
Jaehyun_Cho created T8445: efl.interpolator.
Mon, Oct 28, 7:51 PM · efl (efl-1.24)
Jaehyun_Cho created T8444: efl.canvas.animation_player.
Mon, Oct 28, 7:48 PM · efl (efl-1.24)
Jaehyun_Cho created T8443: efl.canvas.animation_translate.
Mon, Oct 28, 7:47 PM · efl (efl-1.24)
Jaehyun_Cho created T8442: efl.canvas.animation_scale.
Mon, Oct 28, 7:47 PM · efl (efl-1.24)
Jaehyun_Cho created T8441: efl.canvas.animation_rotate.
Mon, Oct 28, 7:47 PM · efl (efl-1.24)
Jaehyun_Cho created T8440: efl.canvas.animation_alpha.
Mon, Oct 28, 7:46 PM · efl (efl-1.24)
Jaehyun_Cho created T8439: efl.canvas.animation_group_sequential.
Mon, Oct 28, 7:46 PM · efl (efl-1.24)
Jaehyun_Cho created T8438: efl.canvas.animation_group_parallel.
Mon, Oct 28, 7:45 PM · efl (efl-1.24)
Jaehyun_Cho created T8437: efl.canvas.animation_group.
Mon, Oct 28, 7:45 PM · efl (efl-1.24)
Jaehyun_Cho created T8436: efl.canvas.animation.
Mon, Oct 28, 7:44 PM · efl (efl-1.24)

Oct 16 2019

Jaehyun_Cho requested review of D10424: csharp: rename Factory.cs to ItemFactory.cs.
Oct 16 2019, 1:37 AM · efl
Jaehyun_Cho accepted D10422: mono: remove underscores of Efl_Op_Description, Efl_Object_Ops.
Oct 16 2019, 1:31 AM · efl

Oct 15 2019

Jaehyun_Cho updated the summary of D10387: efl_ui: rename efl_ui_types.eot to efl_ui_drag_types.eot.
Oct 15 2019, 1:42 AM · efl
Jaehyun_Cho updated the diff for D10387: efl_ui: rename efl_ui_types.eot to efl_ui_drag_types.eot.

Renamed efl_ui_types.eot to efl_ui_drag_types.eot only.

Oct 15 2019, 1:40 AM · efl

Oct 14 2019

Jaehyun_Cho requested review of D10387: efl_ui: rename efl_ui_types.eot to efl_ui_drag_types.eot.
Oct 14 2019, 5:59 AM · efl
Jaehyun_Cho closed D10370: eolian: fix eolian errors with EOLIAN_ENFORCE_SINCE=1.
Oct 14 2019, 12:56 AM · efl

Oct 13 2019

Jaehyun_Cho accepted D10370: eolian: fix eolian errors with EOLIAN_ENFORCE_SINCE=1.
Oct 13 2019, 11:43 PM · efl
Jaehyun_Cho added a comment to D10370: eolian: fix eolian errors with EOLIAN_ENFORCE_SINCE=1.

Except below three - I added @since 1.23 to all none-beta classes.
After getting the proper answers, I'll update this patch (or create new diff).

  1. elm_interface_scrollable.eo
    • Below two enums should be marked as @beta or @since 1.23 ?
      • enum Elm.Scroller.Policy
      • enum Elm.Scroller.Single_Direction

I think these are much older than that?

elm_interface_scrollable.eo.h and elm_interface_scrollable.h are included in Elementary.h only if EFL_BETA_API_SUPPORT is defined.
Therefore, it seems that @beta is right for the above enums as this patch does.

Oct 13 2019, 11:42 PM · efl

Oct 11 2019

Jaehyun_Cho requested review of D10372: efl_ui_panes: fix not to consider content min size for legacy panes.
Oct 11 2019, 6:00 AM · efl

Oct 10 2019

Jaehyun_Cho added a comment to T8288: Animation API.
  • efl_canvas_animation_rotate:
    • Current rotate's cx and cy is double value relative to the pivot object. (e.g. 0.0 ~ 1.0, center is 0.5) So I am not sure if Vector is the correct type for this relative values although value type is the same.

I think Vector2D sounds like the type we want to have for that. Maybe its just me, but i am prefering to have a simple container over two values for the same semantical thing.

Like you said, it may be related to preference. The reason why I am not sure about this is because these parameters have similar values of the parameters of hint_align of efl_gfx_hint.eo.
BTW, I don't have any preference about this case.

I think Vector2D is the correct thing here, my idea would be that the parameters would be in the end (from : Vector2D, to : Vector2D, pivot : Efl.Canvas.Object, c : Vector2D)

Oh, I misunderstood. Now I see. So it is the same as the preference of using Vector2D type.

Mhm, after reading it a second time, i think i am a bit confused here. What is autodel deleting, the animated object, or the player ?

If auto_del is true, then player is deleted when animation ends.

I am actaully a little bit concerend about the amount of objects required something easy as a animation.... esp. with the autodel thing, so you create 2 objects just to delete them. If we publish that like this. Then we have no good way to refactor that later on ... :(

I totally agree with you that we need to reduce the number of objects which are created for easy animation.
I'm sorry I don't understand what you mean about autodel in the later comment. Could you explain please?

Oct 10 2019, 5:43 AM · efl: canvas

Oct 7 2019

Jaehyun_Cho added a comment to T8288: Animation API.

@bu5hm4n Thank you for the description :) I replied as follows.

Oct 7 2019, 5:22 AM · efl: canvas

Sep 30 2019

Jaehyun_Cho requested review of D10248: theme: remove duplicated version 119.
Sep 30 2019, 3:56 AM · efl
Jaehyun_Cho closed D10247: theme: port to efl.ui.clickable and use macro for anchor style.
Sep 30 2019, 12:47 AM · efl
Jaehyun_Cho requested review of D10247: theme: port to efl.ui.clickable and use macro for anchor style.
Sep 30 2019, 12:19 AM · efl

Sep 29 2019

Jaehyun_Cho closed D10246: eolian_mono: support beta for enum if mono-beta is enabled.
Sep 29 2019, 11:52 PM · efl
Jaehyun_Cho updated the test plan for D10246: eolian_mono: support beta for enum if mono-beta is enabled.
Sep 29 2019, 11:10 PM · efl
Jaehyun_Cho updated the test plan for D10246: eolian_mono: support beta for enum if mono-beta is enabled.
Sep 29 2019, 11:10 PM · efl
Jaehyun_Cho updated the summary of D10246: eolian_mono: support beta for enum if mono-beta is enabled.
Sep 29 2019, 11:10 PM · efl
Jaehyun_Cho updated the diff for D10246: eolian_mono: support beta for enum if mono-beta is enabled.

fix typo

Sep 29 2019, 11:10 PM · efl
Jaehyun_Cho requested review of D10246: eolian_mono: support beta for enum if mono-beta is enabled.
Sep 29 2019, 11:08 PM · efl
Jaehyun_Cho closed D10245: eolian_mono: Respect beta for enum.
Sep 29 2019, 9:53 PM · efl
Jaehyun_Cho accepted D10245: eolian_mono: Respect beta for enum.
Sep 29 2019, 9:52 PM · efl
Jaehyun_Cho added a comment to T8231: theme api.

Thank you, I think you are right.

Sep 29 2019, 9:47 PM · efl: api, efl (efl-1.23)
Jaehyun_Cho abandoned D8463: efl_mono: move enum Components out of Csharp namespace.

Abandon unavailable patches.

Sep 29 2019, 7:44 PM · efl
Jaehyun_Cho abandoned D8442: efl_ui_selectable: separate efl_ui_selectable into item and text.

Abandon unavailable patches. The alternative patch exists.

Sep 29 2019, 7:43 PM · DO NOT MERGE, Restricted Project
Jaehyun_Cho abandoned D7373: efl_access: change Efl.Access.Object from mixin to interface.

Abandon unavailable patches.

Sep 29 2019, 7:41 PM · efl
Jaehyun_Cho abandoned D7085: eolian: Set widget and widget item in the same group in doxygen.

Abandon unavailable patches.

Sep 29 2019, 7:40 PM · efl
Jaehyun_Cho abandoned D10018: efl: remove implementation of Efl.Player.

This patch is not appropriate and the alternative patch exists.

Sep 29 2019, 7:38 PM · efl
Jaehyun_Cho added a comment to D10018: efl: remove implementation of Efl.Player.

yes, thank you :)

Sep 29 2019, 7:37 PM · efl

Sep 27 2019

Jaehyun_Cho added a comment to T8231: theme api.

@bu5hm4n
Thank you for your opinion. I agree with you.
Then the following cases should be modified to keep consistency with other part names.
"efl.text.title", "efl.rect.background", "efl.text.status", "efl.swallow.event", "efl.content.hotspot", "efl.spacer.opaque", "efl.spacer.content"

Sep 27 2019, 1:19 AM · efl: api, efl (efl-1.23)
Jaehyun_Cho added a comment to T8231: theme api.

What do you think about using edc part type as a namespace?
i.e. "efl.text.title", "efl.rect.background", "efl.text.status", "efl.swallow.event", "efl.content.hotspot", "efl.spacer.opaque", "efl.spacer.content"

Sep 27 2019, 12:40 AM · efl: api, efl (efl-1.23)

Sep 26 2019

Jaehyun_Cho updated the diff for D10217: theme: replace hbar and vbar to horizontal_bar and vertical_bar.

also replaced missing one

Sep 26 2019, 9:54 PM · efl
Jaehyun_Cho requested review of D10217: theme: replace hbar and vbar to horizontal_bar and vertical_bar.
Sep 26 2019, 9:50 PM · efl
Jaehyun_Cho requested review of D10216: theme: remove efl.track.slider and efl.track2.slider from efl_ui_slider.
Sep 26 2019, 8:03 PM · efl

Sep 25 2019

Jaehyun_Cho added a comment to T8231: theme api.

I categorized the signal names into 4 groups as follows.
I want to discuss how we can categorize signal types. If we are able to categorize signal types, then it would be helpful to choose the right name for it.

Sep 25 2019, 5:23 AM · efl: api, efl (efl-1.23)

Sep 24 2019

Jaehyun_Cho added a comment to T7877: efl.player.

@zmike
Let me explain the each purpose of "start", "stop", "play" as far as I know.

Sep 24 2019, 12:03 AM · efl: api, efl (efl-1.23), efl: language bindings

Sep 23 2019

Jaehyun_Cho added a comment to D10018: efl: remove implementation of Efl.Player.

@zmike
I introduced this patch because many methods of Efl.Player are not fully implemented in its inheriting classes. It is related to T5719.
Is it ok if classes do not fully implement their interface's methods?

Sep 23 2019, 7:26 PM · efl
Jaehyun_Cho closed T8167: C#: Fix indentation and blanklines as Resolved.

@lauromoura yes! thank you :)

Sep 23 2019, 6:58 PM · efl (efl-1.23), Active Work Proposal, Restricted Project, efl: language bindings
Jaehyun_Cho closed T8167: C#: Fix indentation and blanklines, a subtask of T7204: Discussion about C# binding syntax, as Resolved.
Sep 23 2019, 6:58 PM · efl (efl-1.24), Active Work Proposal, Restricted Project, efl: language bindings
Jaehyun_Cho added a comment to D10018: efl: remove implementation of Efl.Player.

@bu5hm4n Thank you for your reply.

Sep 23 2019, 6:53 PM · efl
Jaehyun_Cho closed D9968: elementary: unref objects when memory allocation fails in factory.
Sep 23 2019, 5:16 AM · efl
Jaehyun_Cho added a comment to D10018: efl: remove implementation of Efl.Player.

Is it ok if this is submitted?

Sep 23 2019, 4:13 AM · efl
Jaehyun_Cho added a comment to D9968: elementary: unref objects when memory allocation fails in factory.

Is it ok if this is submitted?

Sep 23 2019, 4:13 AM · efl

Sep 20 2019

Jaehyun_Cho added a comment to T8229: Check essential properties, methods, and enum marked @beta.

In EFL C#, autohide and win_type are necessary to implement a C# application.

Sep 20 2019, 3:02 AM · efl (efl-1.24)

Sep 19 2019

Jaehyun_Cho requested review of D10018: efl: remove implementation of Efl.Player.
Sep 19 2019, 3:39 AM · efl
Jaehyun_Cho updated the diff for D9968: elementary: unref objects when memory allocation fails in factory.

free iterator

Sep 19 2019, 2:49 AM · efl
Jaehyun_Cho updated subscribers of T8229: Check essential properties, methods, and enum marked @beta.

@zmike
Hello~ Do you know the reason why @property win_type, @property autohide are still marked @beta?
e.g. @property win_type is marked @beta because related wayland feature can be changed later?

Sep 19 2019, 12:50 AM · efl (efl-1.24)
Jaehyun_Cho updated the task description for T8229: Check essential properties, methods, and enum marked @beta.
Sep 19 2019, 12:45 AM · efl (efl-1.24)
Jaehyun_Cho created T8229: Check essential properties, methods, and enum marked @beta.
Sep 19 2019, 12:45 AM · efl (efl-1.24)

Sep 18 2019

Jaehyun_Cho added a comment to T8225: [C#] Generate method name beginning with verb.

@lauromoura
As I mentioned in D10001, some words are used as verb in some method names and they are used as noun in other method names.
To resolve this problem, we may need to introduce a new eo syntax.

Sep 18 2019, 1:52 AM · efl: language bindings
Jaehyun_Cho updated the diff for D10001: eolian_mono: add more verbs to generate C# method beginning with verb.

add ref T8225

Sep 18 2019, 1:15 AM · efl
Jaehyun_Cho requested review of D10001: eolian_mono: add more verbs to generate C# method beginning with verb.
Sep 18 2019, 1:13 AM · efl

Sep 17 2019

Jaehyun_Cho created T8225: [C#] Generate method name beginning with verb.
Sep 17 2019, 11:19 PM · efl: language bindings
Jaehyun_Cho added a reviewer for D9968: elementary: unref objects when memory allocation fails in factory: devilhorns.
Sep 17 2019, 6:06 PM · efl
Jaehyun_Cho updated the diff for D9968: elementary: unref objects when memory allocation fails in factory.

Fixed not to keep array and rebased

Sep 17 2019, 6:05 PM · efl

Sep 16 2019

Jaehyun_Cho retitled D9968: elementary: unref objects when memory allocation fails in factory from efl_ui_caching_factory: fix memory leak to elementary: fix memory leak in factory.
Sep 16 2019, 4:19 AM · efl
Jaehyun_Cho updated the diff for D9968: elementary: unref objects when memory allocation fails in factory.

fixing memory leak in efl_ui_widget_factory.c is included

Sep 16 2019, 4:10 AM · efl
Jaehyun_Cho updated the diff for D9968: elementary: unref objects when memory allocation fails in factory.

rename the error name

Sep 16 2019, 3:56 AM · efl
Jaehyun_Cho requested review of D9968: elementary: unref objects when memory allocation fails in factory.
Sep 16 2019, 3:48 AM · efl

Sep 10 2019

Jaehyun_Cho updated the diff for D9891: eolian_mono: fix documentation warning by using "<" and ">".

update indentation

Sep 10 2019, 11:39 PM · efl