Page MenuHomePhabricator

maderios (Marcel Derioss)
User

Projects

User does not belong to any projects.

Today

  • Clear sailing ahead.

Tomorrow

  • Clear sailing ahead.

Wednesday

  • Clear sailing ahead.

User Details

User Since
Feb 27 2013, 7:01 AM (342 w, 4 d)
Availability
Available

Recent Activity

Aug 14 2019

maderios updated the task description for T8132: efl enlightenment git: some svg icons not displayed in ibar.
Aug 14 2019, 7:29 AM · enlightenment-git
Herald updated subscribers of T8132: efl enlightenment git: some svg icons not displayed in ibar.
Aug 14 2019, 7:28 AM · enlightenment-git
Herald added a project to T8132: efl enlightenment git: some svg icons not displayed in ibar: enlightenment-git.
Aug 14 2019, 7:27 AM · enlightenment-git

Jun 26 2019

Herald added a project to T8037: can't restart enlightenment wayland when using GL : enlightenment-git.
Jun 26 2019, 9:10 AM · Restricted Project, enlightenment-git
maderios added a comment to T8029: Can't start efl-git 62436 wayland session.

Yes it works now!

Jun 26 2019, 8:50 AM · enlightenment-git
maderios added a comment to T8029: Can't start efl-git 62436 wayland session.

Bug still present with efl-git-1.22.99.62458

Jun 26 2019, 6:28 AM · enlightenment-git

Jun 21 2019

Herald added a project to T8029: Can't start efl-git 62436 wayland session: enlightenment-git.
Jun 21 2019, 6:42 AM · enlightenment-git

Jun 12 2019

maderios added a comment to T7115: efl-git alpha 1.21 : Enlightenment Wayland session, scrolling firefox bookmarks folders takes a long time.

Good news, this bug seems solved with efl-git 1.22.99.62358 and enlightenment-git 0.23.0.23575

Jun 12 2019, 2:56 AM · Restricted Project, enlightenment-git

May 5 2019

Herald added a project to T7909: [Efl-git] Wayland issues with screen blanking and application launcher in ibar: enlightenment-git.
May 5 2019, 1:56 AM · Restricted Project, enlightenment-git

Mar 12 2019

maderios added a comment to T7737: efl-git 1.22.0beta1.61484 + enlightenment-git: icon menu properties not diplayed (wayland).

Same issue with X environnement

Mar 12 2019, 9:51 AM · enlightenment-git, efl (efl-1.22)
maderios renamed T7737: efl-git 1.22.0beta1.61484 + enlightenment-git: icon menu properties not diplayed (wayland) from efl-git 1.22.0beta1.61484 + enlightenment-git: icon menu properties not diplayed to efl-git 1.22.0beta1.61484 + enlightenment-git: icon menu properties not diplayed (wayland).
Mar 12 2019, 9:42 AM · enlightenment-git, efl (efl-1.22)
maderios created T7737: efl-git 1.22.0beta1.61484 + enlightenment-git: icon menu properties not diplayed (wayland).
Mar 12 2019, 9:39 AM · enlightenment-git, efl (efl-1.22)

Sep 28 2018

maderios added a comment to T7410: enlightenment-git and efl-git eat huge memory.

Until you solve this problem, e works better with this variable. Thanks.

Sep 28 2018, 12:12 PM · Restricted Project, enlightenment-git

Sep 27 2018

maderios added a comment to T7410: enlightenment-git and efl-git eat huge memory.

New valgrind -massif file today, 13 hours running enlightenment.
kernel linux-lts 4.14.71-1
efl-git 1.21.99.59809
enlightenment-git 0.22.99.23417
https://pastebin.com/uVmA2j8C

Sep 27 2018, 2:22 PM · Restricted Project, enlightenment-git

Sep 26 2018

maderios added a comment to T7410: enlightenment-git and efl-git eat huge memory.

It should work
massif file name: 'massif.out.20204'
https://pastebin.com/Y2XsRujj

Sep 26 2018, 9:51 AM · Restricted Project, enlightenment-git
maderios added a comment to T7410: enlightenment-git and efl-git eat huge memory.

I apologize for this huge file. Public pastebin doesn't work for me...

Sep 26 2018, 9:14 AM · Restricted Project, enlightenment-git
maderios added a comment to T7410: enlightenment-git and efl-git eat huge memory.
Sep 26 2018, 9:10 AM · Restricted Project, enlightenment-git
maderios added a comment to T7410: enlightenment-git and efl-git eat huge memory.

Maybe useful:
original massive file is massif.out.20204

Sep 26 2018, 4:42 AM · Restricted Project, enlightenment-git
maderios added a comment to T7410: enlightenment-git and efl-git eat huge memory.

My apologize, paste access is public, now...

Sep 26 2018, 4:35 AM · Restricted Project, enlightenment-git

Sep 25 2018

maderios added a comment to T7410: enlightenment-git and efl-git eat huge memory.

Here is valgrind -massif log. Running enlightenment about 9 hours.
efl-git 1.21.99.59807.ge9e63f3c0d-1
enlightenment-git 0.22.99.23417.ga03700103
https://pastebin.com/C8gq4Khv

Sep 25 2018, 12:35 PM · Restricted Project, enlightenment-git

Sep 21 2018

Herald added a project to T7410: enlightenment-git and efl-git eat huge memory: enlightenment-git.
Sep 21 2018, 10:44 AM · Restricted Project, enlightenment-git

Aug 14 2018

maderios added a comment to T7115: efl-git alpha 1.21 : Enlightenment Wayland session, scrolling firefox bookmarks folders takes a long time.

It seems this annoying bug doesn't come from enlightenment but from wayland. I tested Firefox in a weston session, it's worst!

Aug 14 2018, 10:18 AM · Restricted Project, enlightenment-git

Jul 15 2018

maderios added a comment to T7115: efl-git alpha 1.21 : Enlightenment Wayland session, scrolling firefox bookmarks folders takes a long time.

Bug is still there with efl-git 1.21.0alpha1.59380.g655c5ee6e0-1 (Linux Arch Aur).
It disappears if I restart enlightenment then it reappears after half or one hour.

Jul 15 2018, 4:34 AM · Restricted Project, enlightenment-git

Jul 8 2018

maderios created T7115: efl-git alpha 1.21 : Enlightenment Wayland session, scrolling firefox bookmarks folders takes a long time.
Jul 8 2018, 2:16 AM · Restricted Project, enlightenment-git

Mar 30 2018

maderios added a comment to T6778: I can't use menus with enlightenment-git and efl-git, wayland session.

I get nearly same bugs with last efl-git 1.20.99.58032 and enlightenment-git 0.22.99.23369

  • When I try to click and scroll menu, it disappears or/and flickers with login menus.
  • When I launch wayland session I get error message 'cannot initialize Ecore_X!''

Apps concerned: firefox, digikam, avidemux-qt, thunderbird, gimp, etc...

Mar 30 2018, 2:56 AM · Restricted Project, enlightenment-git

Mar 15 2018

maderios added a comment to T6778: I can't use menus with enlightenment-git and efl-git, wayland session.

Other problem with Gimp: mouse cursor disappears

Mar 15 2018, 11:00 AM · Restricted Project, enlightenment-git
maderios created T6778: I can't use menus with enlightenment-git and efl-git, wayland session.
Mar 15 2018, 5:39 AM · Restricted Project, enlightenment-git
Herald closed T6777: enlightenment-git and efl-git, wayland session: can't use menus as Invalid.

The Enlightenment ticket system is currently receiving high amounts of spam tickets. This ticket has been closed as spam because it lacks both a project and an assignee. If this ticket is not spam, please reopen it after adding these items.

Mar 15 2018, 5:17 AM · Restricted Project

Feb 21 2018

maderios added a comment to T6717: Wayland session: screenshot doesn't work with efl-git and enlightenment-git.

Thanks. Sorry for the noise...

Feb 21 2018, 11:49 AM · enlightenment-git
Herald assigned T6717: Wayland session: screenshot doesn't work with efl-git and enlightenment-git to zmike.
Feb 21 2018, 11:26 AM · enlightenment-git

Feb 20 2018

maderios added a comment to T6644: bugs efl and enlightenment git, wayland sessions.

Arch Aur
https://aur.archlinux.org/packages/efl-git/
https://aur.archlinux.org/packages/enlightenment-git/
wayland session
Same bug with efl-git 1.20.99.57659 and enlightenment-git 0.22.99.23329 when using Digikam I try to move/copy pictures...

Feb 20 2018, 6:56 AM · enlightenment-git

Jan 26 2018

maderios added a comment to T6644: bugs efl and enlightenment git, wayland sessions.

I recompiled efl and e:
wayland session
Same bug with last efl-git 1.20.99.57388.g7255954ccc-1 and enlightenment-git 0.22.99.23318.g3c7f444f1-1
E crashes when using Digikam I try to move picture file from directory to another directory

Jan 26 2018, 5:54 AM · enlightenment-git

Jan 25 2018

maderios updated the task description for T6644: bugs efl and enlightenment git, wayland sessions.
Jan 25 2018, 2:51 PM · enlightenment-git
Herald assigned T6644: bugs efl and enlightenment git, wayland sessions to zmike.
Jan 25 2018, 2:45 PM · enlightenment-git

Jan 17 2018

maderios added a comment to T6606: Enlightenment 0.22.1 crash when lauching two X sessions .
vt switching is not even done by the WM. It's totally an internal matter inside the Xserver

Yes but with e22+wayland, I can switch to tty or another user wayland session. So I'm waiting for wayland to be less buggy...

Jan 17 2018, 1:06 AM · enlightenment-git

Jan 11 2018

maderios added a comment to T6606: Enlightenment 0.22.1 crash when lauching two X sessions .

Yes but only Enlightenment causes the Xserver crash...

Jan 11 2018, 12:16 PM · enlightenment-git
Herald assigned T6606: Enlightenment 0.22.1 crash when lauching two X sessions to zmike.
Jan 11 2018, 11:55 AM · enlightenment-git

Sep 15 2017

maderios added a comment to T6009: Remember window properties doesn't work on enlightenment.

Conditions: Arch system x86-64, self compiled enlightenment 0.21.9 with efl 20.3
This problem happens with e dialog box
settings -> settings panel

properties -> position, size, application size or name (.desktop)

For this window, 'window remember' never remember 'application size or name (.desktop)'

Sep 15 2017, 2:16 AM · enlightenment-git

Sep 14 2017

maderios added a comment to T6009: Remember window properties doesn't work on enlightenment.

Open window, resize it and move it at the screen center
click on
window -> remember -> identifiers -> window name, class, title, type
-> properties -> position, size
-> apply
Close window
Re-open window
window forgot size and position
Modifications disappeared from dialog box

Sep 14 2017, 4:43 AM · enlightenment-git

Sep 12 2017

Herald assigned T6009: Remember window properties doesn't work on enlightenment to zmike.
Sep 12 2017, 2:04 AM · enlightenment-git
maderios created T6009: Remember window properties doesn't work on enlightenment.
Sep 12 2017, 2:02 AM · enlightenment-git

Jul 20 2017

maderios edited the content of Efl Apps Todo.
Jul 20 2017, 5:35 AM
maderios edited the content of Efl Apps Todo.
Jul 20 2017, 5:32 AM
maderios edited the content of Efl Apps Todo.
Jul 20 2017, 2:58 AM

Jul 17 2017

maderios edited the content of Efl Apps Todo.
Jul 17 2017, 2:37 AM

Sep 7 2016

maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.

I report this bug as x11 bug here
https://bugzilla.redhat.com/show_bug.cgi?id=1373834

Sep 7 2016, 2:29 AM · Bug Report

Sep 3 2016

maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.

May be interesting
I got same problem with Lxde and Openbox
No problem with Xfce4, Blackbox, Icewm and Cinnamon...

Sep 3 2016, 8:26 AM · Bug Report

Aug 30 2016

maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.

Bug report is here
https://bugzilla.redhat.com/show_bug.cgi?id=1370929

Aug 30 2016, 12:56 AM · Bug Report

Aug 27 2016

maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.

I compiled efl 18 and e on a fedora 23 under virtualbox.
Software works normally. I can't use gl, it says e is not compiled with opengl but it is
with all mesa devel dependencies and '--with-opengl=full' option
May be virtualbox problem...

Aug 27 2016, 9:02 AM · Bug Report

Aug 25 2016

maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.
In T4415#67584, @raster wrote:

can you try with an older fedora and same efl? fedora24 under vmware/virtualbox/qemu? i might try under a vm if i find some time but i'm pretty busy...

Aug 25 2016, 10:54 AM · Bug Report
maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.
In T4415#67584, @raster wrote:

eh? wtf? so...

before sw worked, and gl didn't.

Yesterday, before update, sw and gl didn't work

after update...

gl works, sw doesn't.

right?

Today, after update, gl works, sw doesn't, but I'm not sure update change something, maybe...

Aug 25 2016, 4:05 AM · Bug Report
maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.
In T4415#67561, @raster wrote:

you were on software? wait - does the issue appear only when in gl? there is no log there.... that can't be right... wait is this in x11 or wayland mode?

Yesterday, after editing efl18 src evas_x_main.c , compiling, installing and configure e, I was on opengl and x11. It didn't work, it was frozen.
May be important: today, i updated my fedora 24 system, libevdev was updated http://koji.fedoraproject.org/koji/buildinfo?buildID=793461
I started e. It works normally, no freeze :)
Then i changed opengl conf to software: it doesn't work, freeze again.
Then I changed software conf to opengl: it works normally
For me, it seems it's software problem, not opengl.

Aug 25 2016, 1:45 AM · Bug Report

Aug 24 2016

maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.
In T4415#67524, @raster wrote:

@maderios well that backtrace says e is "waiting for stuff". timeouts, events etc. to come in... that's a normal state.

so the reason i asked about vsync is that ecore explicitly refuses to render frames faster than the animator tick. it times frame renders exactly to an animator tick. animator ticks by default come from the system clock and are timed at a framerate... 60fps for example is a default value there.

but with specific hardware we open /dev/dri/card0 and ask the gpu to give us vblank/vsync events directly timed to the screen refresh. there is whitelist of known working cards there and everyone else will fail and fall back to the above system clock. that's why i asked you to disable vsync to see if perhaps we were not getting vsync events and that was causing issues because ecore will just refuse to render an update at all until it gets an animator tick.

so that doesnt seem to be the issue... well now the debugging gets hard. the next point of call is if evas is at all doing a swapbuffers.

so first. using gl or software for e's compositor? i shall assume gl right now. is efl built for egl/gles or opengl/glx? if the first we care about EGLSwapBuffers or otherwise glXSwapBuffers.

there is no magic env var you can set to do this... so your best best is this. you will have to recompile efl. you will have to src/modules/evas/engines/gl_x11/evas_x_main.c -> open that file in an editor. the eng_outbuf_flush() function is the one you are interested in. that will call the appropriate swapbuffers command. so see the ''#ifdef'' GL_GLES - that section until ''#else'' is for egl/gles. the stuff from ''#else'' to the last ''#endif'' in that func is for glx/opengl. so if you are built for glx/opengl then add a:

static int frame = 0;
printf("SWAP %i\n", frame++);

right above glXSwapBuffers() (or if egl/gles right above glsym_eglSwapBuffersWithDamage() or eglSwapBuffers() - make the printfs different strings so you know which is happening).

now from your .xsession make enlightenment_start redirect stdout like:

enlightenment_start > ~/swaplog.txt

then see... do you get swaps with frame numbers happen while the screen isn't updating. simple: tail -f ~/swaplog.txt from a terminal in e... move mouse. do you see a whole bunch of swapbuffer prints with frame numbers appear at once after not moving mouse for a while? or does only 1 appear on the first mouse move then every move after that another line? basically i'm wondering if we're swapping buffers - which we should be, but somehow x is refusing to display them. i kind of have a hunch you have a problem over on the xserver side and i'm bisecting to see if we are trying to swap at all. if we are - then the issue lies inside your gl driver libraries or the xserver itself and whatever 2d driver it has and any options it may be given. if we are NOT swapping... then the issue lies higher up - next port of call - is evas_render() being called by ecore_evas at all? have to bisect and find where in the pipeline the issue is.

i have never seen this issue before. not on nvidia, nouveau, intel or radeon. on any of my machines. i suspect the issue stems from something that is different on your machine to any of mine... thus why i currently suspect something lower level. but let's see.

Aug 24 2016, 9:13 AM · Bug Report

Aug 23 2016

maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.

I don't know if it's useful, I produced backtrace

Aug 23 2016, 10:46 AM · Bug Report
maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.
In T4415#67389, @raster wrote:

@maderios ... im wondering if this is a vsync event issue for you. can you set the following environment variable prior to running e:

export ECORE_NO_VSYNC=1

e.g. from your ~/xsession or ~/.xinitrc or /etc/profile just launch e manually from a tty and set that env var... however you like...

Aug 23 2016, 1:13 AM · Bug Report

Aug 22 2016

maderios added a comment to T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.
In T4415#67309, @raster wrote:

what gfx card/driver?

Aug 22 2016, 10:26 AM · Bug Report
maderios renamed T4415: enlightenment-0.21.2 and 0.20.9 odd behavior from enlightenement-0.21.2 and 0.20.9 odd behavior to enlightenment-0.21.2 and 0.20.9 odd behavior.
Aug 22 2016, 6:23 AM · Bug Report
maderios created T4415: enlightenment-0.21.2 and 0.20.9 odd behavior.
Aug 22 2016, 6:21 AM · Bug Report