Sometimes I make releases without compile testing.
- User Since
- Jan 24 2013, 12:55 AM (317 w, 4 h)
Fri, Feb 15
Yea seems fine on the rename. As for method naming, I meant that prepare_logical is not a super informative method name. What does efl_ui_focus_object_prepare_logical even mean at first glance? Nothing, at least to me...
Closing this since we're removing the interface.
So I think all we need here is to rename the event? I'm on it.
The method naming here seems a bit uninformative?
Why does this have a moved event?
What's going on here?
I've created patches for the above, though the new properties lack implementations. This can be solved at a later point.
So maybe something like:
(E) focus,in (E) focus,out
I don't think there's any way this makes it for 1.22 given that it goes with T7575 and requires dnd/selection types...
Not totally sold on hint_margin naming? Was this hint_padding or similar at some point?
is_frame_object seems bad to expose since this should only be used by internals?
This seems like it has some overlap with T7584?
If someone gives me a tl;dr of what's happening I can take care of this
I don't know what this is so I removed it
Good catch, the @beta patch came in while I was doing this so I guess I messed up the rebase.
Thu, Feb 14
seats method is not implemented by anything at present btw.
Yeah, I think a lot of this was slapped together a bit hastily.
Thanks! I changed the i declaration to be unsigned int to avoid a signedness compiler warning when landing.
seat is a widely used term meaning "group of devices", where a device is the representation of a physical input device. Not sure what you mean by "device ID"; sometimes an int is associated with a device/seat based on arbitrary ordering in the display backend.
Wed, Feb 13
Actually, I'm not sure I like using the word "move" here since that relates to position. What if we use raise_to_top and lower_to_bottom instead to ensure that we're always using terms that correspond to the API. Thoughts?
I think device,changed is slightly ambiguously named given that there are also added and removed events; for example, if I hook changed then is that triggered with the other two?
Okay, I'll just take care of it. Thx!
Can you convert this to a for loop to make it a bit more readable? Otherwise seems like a good fix.
I'm also somewhat confused by the existence of group_member_is, which seems like it exists in order to check whether an object is parented to an event grabber? Otherwise one would just check the object's render_parent property.
This makes sense. Can you reformat the commit log to be more like
Tue, Feb 12
edited because base and step are no longer here
- It feels weird to me that there's no events for this class. At a minimum I would expect member,added and member,removed
- Why are the methods named add and del when we use add and remove in the rest of efl?