HomePhabricator
Python-EFL 1.14.0 release

Python-EFL 1.14.0 release

We are pleased to announce that Python-EFL 1.14.0 is now released and available for download.

More information about the python bindings can be found at:
https://phab.enlightenment.org/w/projects/python_bindings_for_efl/


What's New

Fixes

  • Fixed evas.Textgrid to not leak on cellrow_set()

Improvements

  • Re-added evas.SmartObject (with incompatible API compared to the earlier incarnation) and made elm.Object inherit from it.
  • Better init/shutdown management in all modules, no more need to manually call those functions (no harm in doing it though).

Changes

  • elm.List.callback_highlighted_add: Added item param to func
  • elm.List.callback_unhighlighted_add: Added item param to func
  • elm.Toolbar.callback_clicked_add: Added item param to func
  • elm.Toolbar.callback_longpressed_add: Added item param to func
  • elm.Slideshow: item_data are now a single value, instead of args/kargs, like is implemented in Gengrid/Genlist

Additions

  • evas.Smart
  • evas.Image.orient
  • edje.Edje.text_class_get
  • edje.text_class_get
  • elm.systray
  • elm.Configuration.window_auto_focus_animate
  • elm.Configuration.window_auto_focus_enable
  • elm.Image.memfile_set
  • elm.MultiButtonEntry.callback_item_longpressed_add
  • elm.MultiButtonEntry.callback_item_longpressed_del
  • elm.NaviframeItem.pop_cb_set
  • elm.Photocam.image_orient
  • elm.Scrollable.loop
  • elm.Slider.indicator_visible_mode
  • elm.Transit.go_in
  • elm.on_config_all_changed
  • elm.on_ethumb_connect
  • elm.on_policy_changed
  • elm.on_process_background
  • elm.LayoutClass.file is now also readable
  • elm.Video.file is now also readable

Deprecation

  • evas.Rect.intercepts: Use intersects() instead

Building and Dependencies

PYPI

The package is available on pypi, that means you should be able to install using pip:

pip install python-efl

Manual Install

If you have existing Python-EFL or the old split 1.7 release bindings
installed, you may wish to uninstall them before compiling and installing
to avoid possible conflicts during install and/or runtime.

To build the bindings you will need the following libraries:

  • python (Python 2.6+/3.2+)
  • efl (1.14)
  • elementary (1.14)
  • python-dbus (0.83+)

If you wish to compile using the Cython sources:

  • cython (0.21+)

To install the bindings run:

(sudo) python setup.py install

To generate the documentation locally you need:

  • sphinx (1.1+)
  • graphviz (optional)

To build the documentation:

python setup.py build_doc

For more information on available build options see:

python setup.py --help

Download

For convenience the tarballs contain both the Cython sources and generated intermediary C sources, meaning you do not need Cython to compile the bindings. Full cython sources are also publicly accessible from our git repository at:

https://git.enlightenment.org/bindings/python/python-efl.git/

Projects using Python-EFL

... and many more that cannot fit in this short list.

Written by kuuko on May 7 2015, 2:47 AM.
Binder of all things that go hissssss.
Projects
None
Subscribers
None