efl_canvas_animation: rename Animation_XXX to XXX_Animation
In animation classes, "Animation" is not used as a namespace but it is
used as a prefix in the class names.
However, those classes are basically animation classes with different
features. Therefore, "Animation" should be used as a postfix in the
e.g. Efl.Canvas.Animation_Alpha -> Efl.Canvas.Alpha_Animation
However, for the easier usage of C APIs, c_prefix of animation classes
are remained to be "efl_animation_xxx".
Reviewers: segfaultxavi, bu5hm4n, zmike, Hermet, jsuya
Differential Revision: https://phab.enlightenment.org/D11108