HomePhabricator

Require render version 0.11 before using XRenderCreateSolidFill().

Authored by kwo.

Description

Require render version 0.11 before using XRenderCreateSolidFill().

Apparently use of XRenderCreateSolidFill() may trigger high Xorg cpu
usage (seen on Xorg 1.7.7 with render 0.10, driver unknown).
Exact reason unknown, maybe a driver problem.

Requiring render version >= 0.11 may just be a random way to avoid
some brokenness in older Xorgs.

Details

Committed
kwoJun 18 2015, 12:00 PM
Parents
rESIXf4b11e47ec63: Fix stacking when there is only one window.
Branches
Unknown
Tags
Unknown