HomePhabricator

build: e_gadget_loader is using dlsym

Authored by Marcel Hollerbach <marcel@osg.samsung.com> on Oct 9 2018, 12:20 PM.

Description

build: e_gadget_loader is using dlsym

but is not explicitly linking against it. Previously this was not
discovered due to a wrong flag in elementaries pkgconfig. However - the
new .pc file of elementary does not contain dl anymore (as no library
_needs_ to link against it when using elm). So we need to link this here
explicitly

Differential Revision: https://phab.enlightenment.org/D7150

Marcel Hollerbach <marcel@osg.samsung.com> committed rEa188cfec0e6b: build: e_gadget_loader is using dlsym (authored by Marcel Hollerbach <marcel@osg.samsung.com>).Oct 10 2018, 5:51 AM