Page MenuHomePhabricator

DO NOT MERGEProject
ActivePublic

Members

  • This project does not have any members.

Watchers

  • This project does not have any watchers.

Details

Description

For patches which should not yet be merged

Recent Activity

Thu, Nov 14

segfaultxavi added a comment to D10615: introduce efl_canvas_object_animation.

Adds @method animation_revert(void) to Efl.Canvas.Animation

Thu, Nov 14, 7:43 AM · efl
Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

This is already done for all @move Efl.Object parameters, like setting the manager in the Container and setting the animation in this patch.

Thu, Nov 14, 7:06 AM · efl
Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

@segfaultxavi @bu5hm4n
I missed asking you one more thing in the original comment.

Thu, Nov 14, 6:57 AM · efl
lauromoura added a comment to D10615: introduce efl_canvas_object_animation.

As StartAnimation receives their animation object by @move, the C# binding will automatically call efl_ref for it.

@lauromoura
It would be a good idea! We need to check if it would be fine for all other @move cases. (e.g. @property manager of Efl.Ui.Spotlight.Container)
But I think it would be fine for other @move cases as well :)

Thu, Nov 14, 6:52 AM · efl
Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

As StartAnimation receives their animation object by @move, the C# binding will automatically call efl_ref for it.

Thu, Nov 14, 6:13 AM · efl
lauromoura added a comment to D10615: introduce efl_canvas_object_animation.
Thu, Nov 14, 4:45 AM · efl
Jaehyun_Cho updated subscribers of D10615: introduce efl_canvas_object_animation.

@segfaultxavi @bu5hm4n
Thank you very much for the comments! :)

Thu, Nov 14, 3:26 AM · efl

Wed, Nov 13

bu5hm4n added a comment to D10615: introduce efl_canvas_object_animation.

I think this is pretty fine like it is now, there are 2 more things that need to migrate away from player, but that does not block this revision here.

Wed, Nov 13, 12:01 PM · efl
segfaultxavi added a comment to D10615: introduce efl_canvas_object_animation.

I think API-wise I have no more comments for this patch (pending the end of the discussion).

Wed, Nov 13, 9:33 AM · efl
bu5hm4n updated the diff for D10615: introduce efl_canvas_object_animation.

asdfasdf

Wed, Nov 13, 9:08 AM · efl
bu5hm4n updated the diff for D10615: introduce efl_canvas_object_animation.

its efl canvas now.

Wed, Nov 13, 8:31 AM · efl
bu5hm4n updated the diff for D10615: introduce efl_canvas_object_animation.

renames

Wed, Nov 13, 7:20 AM · efl
segfaultxavi added a comment to D10615: introduce efl_canvas_object_animation.

Thanks for this analysis of the situation. @bu5hm4n and I have been talking about it and we agree on almost everything, but we'd like to make some clarifications:

Wed, Nov 13, 6:14 AM · efl
bu5hm4n edited parent revisions for D10615: introduce efl_canvas_object_animation, added: 1; removed: 1.
Wed, Nov 13, 5:00 AM · efl

Tue, Nov 12

Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

I share the collected opinions about refactoring of Canvas Animation as follows.

Tue, Nov 12, 11:10 PM · efl

Mon, Nov 11

segfaultxavi updated subscribers of D10615: introduce efl_canvas_object_animation.

I propose an unification of all animation flags in D10645 which should clarify things.
If you make this patch depend on D10645 (and rebase) you should be able to rename animation_object to just animation. How does that sound, @bu5hm4n @Jaehyun_Cho @zmike @cedric?

Mon, Nov 11, 8:36 AM · efl
bu5hm4n added inline comments to D10615: introduce efl_canvas_object_animation.
Mon, Nov 11, 3:45 AM · efl
segfaultxavi added inline comments to D10615: introduce efl_canvas_object_animation.
Mon, Nov 11, 2:58 AM · efl
Jaehyun_Cho added a comment to D10615: introduce efl_canvas_object_animation.

I am afraid I need some more time (1 or 2 days) to give you opinion about this animation refactorying work.

Mon, Nov 11, 2:31 AM · efl
bu5hm4n planned changes to D10615: introduce efl_canvas_object_animation.
Mon, Nov 11, 1:54 AM · efl
segfaultxavi added inline comments to D10615: introduce efl_canvas_object_animation.
Mon, Nov 11, 1:25 AM · efl

Sun, Nov 10

bu5hm4n added a child revision for D10615: introduce efl_canvas_object_animation: D10636: elementary: move away from normal player to the new animation mixin.
Sun, Nov 10, 2:14 PM · efl
bu5hm4n updated the diff for D10615: introduce efl_canvas_object_animation.

more tests, and a simple fix

Sun, Nov 10, 2:14 PM · efl
bu5hm4n updated the diff for D10615: introduce efl_canvas_object_animation.

fix animation. position is now returned *always* from 0.0 to 1.0

Sun, Nov 10, 3:51 AM · efl

Thu, Nov 7

lauromoura added a comment to D9717: csharp: Revamp dotnet support.

@lauromoura
Is there any reason not to use csc directly?
csc has been available since mono 5.0.0 ( https://www.mono-project.com/docs/about-mono/releases/5.0.0/#c-compiler )

Thu, Nov 7, 12:30 PM · DO NOT MERGE, efl
segfaultxavi added inline comments to D10615: introduce efl_canvas_object_animation.
Thu, Nov 7, 9:39 AM · efl
bu5hm4n updated the diff for D10615: introduce efl_canvas_object_animation.

add a example

Thu, Nov 7, 5:52 AM · efl
bu5hm4n updated the diff for D10615: introduce efl_canvas_object_animation.
Thu, Nov 7, 4:58 AM · efl
bu5hm4n added a project to D10615: introduce efl_canvas_object_animation: DO NOT MERGE.
Thu, Nov 7, 2:31 AM · efl
YOhoho added a comment to D9717: csharp: Revamp dotnet support.

@lauromoura
Is there any reason not to use csc directly?
csc has been available since mono 5.0.0 ( https://www.mono-project.com/docs/about-mono/releases/5.0.0/#c-compiler )

Thu, Nov 7, 2:21 AM · DO NOT MERGE, efl

Wed, Nov 6

lauromoura closed D9717: csharp: Revamp dotnet support.
Wed, Nov 6, 6:42 AM · DO NOT MERGE, efl

Tue, Oct 29

lauromoura updated the diff for D9717: csharp: Revamp dotnet support.

I put the wrong assembly name for mono...

Tue, Oct 29, 2:07 PM · DO NOT MERGE, efl
lauromoura updated the diff for D9717: csharp: Revamp dotnet support.

Rebase and update after D10337 added friendly assemblies

Tue, Oct 29, 1:53 PM · DO NOT MERGE, efl

Mon, Oct 28

zmike added a project to D10105: test: add a new testcase for paging of scroller: DO NOT MERGE.

Disregard comments re: mainloop iterate as these tests do require a rendered frame.

Mon, Oct 28, 6:03 AM · DO NOT MERGE, efl

Fri, Oct 25

zmike updated the diff for D10528: tests/genlist: add behavior testing for nearly all genlist events.

tweak item move test coords to pass on CI

Fri, Oct 25, 12:34 PM · efl
felipealmeida added a comment to D10432: eolian: Add user keywords to methods and classes for bindings.

IMO, using tags for error is not the best way. A typedef is much better. However, this tag is important for things that are, possibly, platform-specific. So you can tag that a method is not going to be generated for Tizen, for example.

Fri, Oct 25, 11:16 AM · DO NOT MERGE, efl
zmike added a project to D10528: tests/genlist: add behavior testing for nearly all genlist events: DO NOT MERGE.

This is breaking travis somehow, still working on getting it to be consistent enough to land...

Fri, Oct 25, 11:09 AM · efl
segfaultxavi added a comment to D10432: eolian: Add user keywords to methods and classes for bindings.

Hrmm.... then we are in the same situation. There's tags meant for eolian and there's tags meant for the bindings generator, but the guy creating a new EO file does not care about that distinction and will be utterly confused, unless he created the tag.
I mean, if I am creating Eo files and I need a custom tag, then I'm fine, no confusion.
But for the case we were trying to solve (reporting when a bool is indicating an error), I will need to remember that this tag is written differently than all other eolian tags.

Fri, Oct 25, 1:27 AM · DO NOT MERGE, efl

Thu, Oct 24

lauromoura added a comment to D10432: eolian: Add user keywords to methods and classes for bindings.
  1. Use @ in both cases, so user keywords cannot use names already in use by eolian. Downside: if we add more eolian tags in the future, we might break already-existing EO files some people might have created with user keywords.

    ....

    I like option 1 better. It means that any @tag eolian does not recognize is just stored as a user keyword. This also means that mispellings like @proprety won't be detected.
Thu, Oct 24, 1:19 PM · DO NOT MERGE, efl
segfaultxavi added a comment to D10432: eolian: Add user keywords to methods and classes for bindings.

I am not sure I like the #tag syntax. From the user's perspective, some tags will need @ and some others #, for no apparent reason.

Thu, Oct 24, 8:36 AM · DO NOT MERGE, efl

Oct 19 2019

felipealmeida updated the diff for D10432: eolian: Add user keywords to methods and classes for bindings.

Use eina_hash_population as reviewed by YOhoho.

Oct 19 2019, 6:33 AM · DO NOT MERGE, efl
felipealmeida updated the diff for D10432: eolian: Add user keywords to methods and classes for bindings.

Added property and class support

Oct 19 2019, 6:26 AM · DO NOT MERGE, efl

Oct 16 2019

lauromoura added a child revision for D9717: csharp: Revamp dotnet support: D10433: csharp: Add StyleCop support to dotnet build.
Oct 16 2019, 8:18 PM · DO NOT MERGE, efl
lauromoura added inline comments to D10432: eolian: Add user keywords to methods and classes for bindings.
Oct 16 2019, 7:45 PM · DO NOT MERGE, efl
YOhoho added a comment to D10432: eolian: Add user keywords to methods and classes for bindings.

You can use eina_hash_population to get the number of hash elements.

Oct 16 2019, 7:13 PM · DO NOT MERGE, efl
felipealmeida added reviewers for D10432: eolian: Add user keywords to methods and classes for bindings: lauromoura, woohyun, segfaultxavi, q66.

This is a partial implementation, but shows how to use on the test. It is still specific to methods only on this diff. But I'll expand to other entities.

Oct 16 2019, 5:21 PM · DO NOT MERGE, efl

Oct 14 2019

lauromoura added a project to D10367: csharp: Do not generate wrapper for setter returning values.: DO NOT MERGE.
Oct 14 2019, 2:43 PM · DO NOT MERGE, efl

Oct 3 2019

lauromoura updated the diff for D9717: csharp: Revamp dotnet support.

Update with support for dotnet core 3.0

Oct 3 2019, 4:08 AM · DO NOT MERGE, efl

Oct 2 2019

lauromoura updated the diff for D9717: csharp: Revamp dotnet support.

Also added a declaration of Efl.ObjectRealized using Efl.Object.NativeMethods as its NativeClass attribute. The hidden class test was failing in dotnet without it, as the class map when marshalling from C was not finding it.

Oct 2 2019, 8:43 PM · DO NOT MERGE, efl
lauromoura planned changes to D9717: csharp: Revamp dotnet support.

Needs rebase after the release.

Oct 2 2019, 3:02 PM · DO NOT MERGE, efl